Ethereum Network Transactions Delayed 7/22/24
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 14:28 EDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2024 - 12:47 EDT
This incident affected: Crypto Deposits and Withdrawals.