Fiat Advanced Funds Deposits
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 20:30 EDT
Identified
Some users may not receive their funds immediately for use on advance when making a deposit into their Gemini account. This issue has been identified and we are actively monitoring the situation. All funds and Gemini accounts remain completely secure. We will provide additional updates as they become available.
Posted Jun 01, 2023 - 18:02 EDT
This incident affected: Fiat Deposits and Withdrawals.