Delayed Solana Transactions

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Mar 28, 2026 - 10:06 EDT

Investigating

We are currently investigating an issue impacting a delay in Solana transactions. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Mar 27, 2026 - 13:07 EDT
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).