New customer registration issue
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 15, 2019 - 18:55 EDT
Investigating
New customer registrations are encountering errors. The issue has been identified and we are working on a solution.
Posted Jul 15, 2019 - 16:44 EDT
This incident affected: Exchange Web Interface.