Degraded Performance - XRP deposits & withdrawals are currently delayed
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 11, 2024 - 22:01 EST
Investigating
XRP deposits and withdrawals are currently delayed, we are working to address the issue. All customer accounts and funds remain secure. Further updates to follow.
Posted Feb 10, 2024 - 23:58 EST
This incident affected: Gemini Mobile App, Gemini Web UI and Digital Currencies (XRP Deposits & Withdraw).