Singapore Withdrawals Temporarily Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Aug 05, 2026 - 23:08 EDT

Update

We are continuing to investigate this issue.
Posted Aug 05, 2026 - 22:45 EDT

Update

Some customers in Singapore are currently unable to withdraw funds on web and mobile due to no available payment methods. Our team is investigating and will provide updates as work continues. All customers' assets remain secure.
Posted Aug 05, 2026 - 22:45 EDT

Investigating

We are currently investigating this issue.
Posted Aug 05, 2026 - 22:37 EDT
This incident affected: Fiat Deposits and Withdrawals.