SUI Chain Monitor Not Processing Blocks

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 07, 2026 - 22:02 EDT

Update

We are continuing to investigate this issue.
Posted May 07, 2026 - 18:09 EDT

Investigating

SUI deposits and withdrawals temporarily unavailable.
Posted May 07, 2026 - 18:09 EDT
This incident affected: Crypto Deposits and Withdrawals.