Degraded Performance - Delays in ETH/ERC20, ATOM and XRP Deposits and Withdrawals.
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 02:06 EST
Investigating
Our team is aware of the delays in ETH/ERC20, ATOM, and XRP deposits and withdrawals, and we are currently investigating the issue. All customer accounts and funds remain secure. Further updates will follow.
Posted Dec 04, 2024 - 22:58 EST
This incident affected: Digital Currencies (Ethereum Deposits and Withdrawals, Cosmos Deposits and Withdrawals, XRP Deposits & Withdraw) and Crypto Deposits and Withdrawals.