Trading Pause - LTCUSD, ZECUSD, BCHUSD
Incident Report for Gemini Exchange
Resolved
Trading has resumed on all order books and the underlying issue has been resolved.
Posted Dec 13, 2019 - 22:41 EST
Identified
Gemini is currently investigating an issue impacting the LTCUSD, ZECUSD and BCHUSD order books. Trading has been paused on these books while the issue is investigated and corrected. All customer funds remain safe at this time.
Posted Dec 13, 2019 - 17:41 EST
This incident affected: Exchange Trading Engine.