Service Disruption - Optimism Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jun 25, 2024 - 17:41 EDT
Update
We are continuing to investigate this issue.
Posted Jun 25, 2024 - 17:40 EDT
Investigating
We are currently investigating an issue preventing Optimism withdrawals from successfully completing. All customer funds remain secure. We will update this page with more information once it is available.
Posted Jun 25, 2024 - 16:03 EDT
This incident affected: Digital Currencies (Optimism Deposits and Withdrawals).