Service Disruption - Gemini Earn Page Delays
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 05, 2022 - 15:38 EST
Identified
Gemini is investigating reports of potential service disruptions when loading the Gemini Earn pages on Web and Mobile interfaces. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Jan 05, 2022 - 15:30 EST
This incident affected: Gemini Earn.