BTC, ETH, ZEC, BCH, GUSD, LTC deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
Required maintenance completed.
Posted 5 months ago. May 01, 2019 - 20:51 EDT
Monitoring
BTC, ETH, ZEC, BCH, GUSD, LTC deposits and withdrawals are temporarily unavailable while we perform a required update. All customers’ assets remain secure. We will provide a further update when completed.
Posted 5 months ago. May 01, 2019 - 20:41 EDT
This incident affected: Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, Litecoin Deposits & Withdrawals, Zcash Deposits & Withdrawals, Bitcoin Cash Deposits & Withdrawals, and Gemini Dollar Withdrawals & Redemptions.