Executed order history degraded
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 10, 2024 - 09:33 EST
Investigating
We are currently investigating delays regarding Order History for some users. Affected users may not see recent orders appear immediately in their Order History. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Dec 04, 2024 - 14:21 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95%, Gemini Web UI: Uptime SLA 99.95%, and REST API.