XRPL chain-monitor finalization stalled

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 27, 2026 - 20:19 EDT

Update

We are continuing to investigate this issue.
Posted Jun 27, 2026 - 20:18 EDT

Update

We are continuing to investigate this issue.
Posted Jun 26, 2026 - 15:47 EDT

Update

We are continuing to investigate this issue.
Posted Jun 26, 2026 - 15:20 EDT

Investigating

We are currently investigating delays affecting crypto deposits and withdrawals on the XRP Ledger (XRPL) network.
Posted Jun 26, 2026 - 15:19 EDT
This incident affected: Digital Currencies (XRP Deposits & Withdraw).