Instant Order Delayed

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Oct 10, 2025 - 20:53 EDT

Investigating

Gemini is currently investigating an intermittent issue that is affecting Instant Orders processed with credit cards.
Posted Oct 10, 2025 - 20:00 EDT
This incident affected: Gemini ActiveTrader™ and Gemini Mobile App: Uptime SLA 99.95%.