AUDIO Deposits & Withdrawals Temporarily Unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 24, 2022 - 12:10 EDT
Investigating
We are investigating the issue. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Jul 24, 2022 - 00:56 EDT
This incident affected: Digital Currencies (Audius Deposits and Withdrawals).