Mobile Users In Advanced Mode May Experience Issues Viewing Trade Tab
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 10, 2025 - 13:49 EST
Investigating
We are currently investigating the Trade tab being impacted on mobile for users in advanced mode. Users impacted by this should switch to simple mode in the meantime while this is investigated. All customer accounts and funds remain secure. Further updates to follow.
Posted Jan 10, 2025 - 13:30 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.