Possible delay in closure of prediction markets

Incident Report for Gemini Exchange

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 09, 2026 - 09:29 EDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 09, 2026 - 08:54 EDT

Identified

We experienced some delays in closure of a small number of prediction markets. This may result in delays in crediting the cash settlement for correct predictions.

We are working on a fix and will update as soon as more information is available.
Posted Mar 09, 2026 - 08:44 EDT
This incident affects: Exchange Trading Engine.