ETH deposits and withdrawals - Degraded Performance
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 12, 2018 - 17:24 EST
Monitoring
Due to unprecedented levels of Ethereum network congestion, ETH deposits and withdrawals may be delayed by up to two hours. If you encounter an error during an ETH withdrawal, it may result in a temporary “hold” on your account balance while our Ethereum system attempts to send your withdrawal out to the blockchain. Please do not retry your withdrawal, as that will result in multiple transactions.
Posted Jan 04, 2018 - 14:59 EST