Service disruption: Issues loading the Advanced Trade page on mobile
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 16:35 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2024 - 14:06 EST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2024 - 10:41 EST
Update
We are continuing to investigate this issue.
Posted Feb 09, 2024 - 10:38 EST
Investigating
We are experiencing intermittent issues loading the Advanced Trade page on mobile
Posted Feb 09, 2024 - 08:57 EST
This incident affected: Gemini ActiveTrader™ and Gemini Mobile App.