Long loading times on some pages

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 17, 2026 - 22:48 EDT

Identified

Customers might occasionally experience long loading time of the order, trade or transaction history pages.

Our team is working on a fix, and updates will be provided once they are available.
Posted May 14, 2026 - 07:33 EDT

Investigating

Customers might occasionally experience long loading time of the order, trade or transaction history pages.

Our team is working on a fix, and updates will be provided once they are available.
Posted May 14, 2026 - 07:32 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.