Delays to Withdrawals Processing - 12/20/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 20, 2024 - 18:33 EST
Update
We are continuing to investigate this issue. Deposits and withdrawals for both fiat and crypto are temporarily disabled.
Posted Dec 20, 2024 - 16:24 EST
Update
We are continuing to investigate this issue.
Posted Dec 20, 2024 - 16:18 EST
Investigating
We are currently investigating an issue delaying withdrawal processing. All customer accounts and funds remain secure. Further updates to follow.
Posted Dec 20, 2024 - 15:55 EST
This incident affected: Fiat Deposits and Withdrawals and Crypto Deposits and Withdrawals.