Service Disruption - Wire Deposits and Withdrawals
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Apr 21, 2021 - 17:03 EDT
Identified
Gemini is investigating reports of potential service disruptions with respect to AUD, CAD, EUR, GBP, HKD and SGD wire deposits and withdrawals as well as BLINC processing for EUR and GBP. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Apr 21, 2021 - 09:57 EDT
This incident affected: Wire Transfer Deposit and Withdrawals.