Gemini Credit Card customers currently unable to use the 'Add to Apple Wallet' button to add their card to Apple Wallet.
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Feb 07, 2025 - 12:00 EST
Investigating
We are aware of the issue and working on a resolution. All your funds remain secure. Thank you for your support!
Posted Feb 03, 2025 - 05:50 EST
This incident affected: Gemini Credit Card™.