Exchange Maintenance Mode

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jul 21, 2025 - 02:18 EDT

Update

Please note we are currently going in maintenance mode. And will update asap on further status. Thanks.
Posted Jul 21, 2025 - 01:19 EDT

Update

We are continuing to investigate this issue.
Posted Jul 21, 2025 - 01:18 EDT

Investigating

Gemini is currently investigating an issue with trading for some users. We will share more updates here as our investigation progresses. All customer accounts and funds remain secure. Further updates to follow.
Posted Jul 21, 2025 - 00:54 EDT
This incident affected: Gemini ActiveTrader™, Gemini Mobile App: Uptime SLA 99.95%, Gemini Web UI: Uptime SLA 99.95%, Gemini.com website, Exchange Trading Engine, REST API, FIX API, Websockets API, and Recurring Orders.