SOLUSD, FETUSD Service Increment Adjustment
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Sep 23, 2024 - 11:42 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 19, 2024 - 09:27 EDT
Investigating
All customer accounts and funds remain secure. Further updates to follow.
Posted Sep 18, 2024 - 13:38 EDT
This incident affected: Digital Currencies (Fetch AI Deposits and Withdrawals, Solana Deposits and Withdrawals).