We are investigating reports of delays in Earn Redemptions
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted May 12, 2022 - 16:52 EDT
Identified
We identified an issue with some Earn redemptions not appearing in trading balances after the redemption was complete. All funds have arrived from our partner and we are working on distributing them to customers as quickly as possible. We will contact affected users. Additional redemptions will be unaffected.
Posted May 12, 2022 - 10:44 EDT
Investigating
Gemini is investigating reports of potential delays in earn redemptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted May 12, 2022 - 09:43 EDT
This incident affected: Gemini Earn.