Timeouts in Monthly Account Statements Generation

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Sep 07, 2022 - 00:22 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 06, 2022 - 22:11 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 06, 2022 - 22:10 EDT

Investigating

We are currently investigating reports where clients' requests to download certain monthly statements are timing out. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Sep 06, 2022 - 12:53 EDT
This incident affected: Gemini Web UI: Uptime SLA 99.95%.