Gemini.com Public Website Unavailable

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Jun 06, 2026 - 13:56 EDT

Investigating

We are currently investigating issue. Issue affecting Gemini website which is currently unavailable. All funds remain secure. We will provide updates as they become available.
Posted Jun 06, 2026 - 05:25 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%, Gemini Web UI: Uptime SLA 99.95%, and Gemini.com website.