Forgot Password on Mobile App not Working

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 30, 2025 - 11:59 EDT

Investigating

Forgot Password on the mobile app is failing, please use the web experience to reset password while we investigate this issue.
Posted May 21, 2025 - 11:52 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.