Service Disruption - AMPUSD Mobile Sell Orders
Incident Report for Gemini Exchange
Resolved
The issue impacting mobile sell orders in AMPUSD has been resolved in the latest version of the Gemini mobile app. Please update your Gemini Mobile app to the latest version (v2.20.1) at your earliest convenience.
Posted Sep 17, 2020 - 15:15 EDT
Investigating
Gemini is investigating reports of potential service disruptions with AMPUSD mobile sell orders. Web and ActiveTrader AMPUSD sell orders are fully functional. Further updates to follow.
Posted Sep 16, 2020 - 11:48 EDT
This incident affected: Gemini Mobile App: Uptime SLA 99.95%.