Instant Quotes Not Working

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 19, 2026 - 22:03 EDT

Update

We are continuing to investigate this issue.
Posted May 19, 2026 - 20:53 EDT

Investigating

Customers are unable to place instant cryptocurrency orders.
Posted May 19, 2026 - 20:52 EDT
This incident affected: Gemini ActiveTrader™ and Crypto Deposits and Withdrawals.