XRP deposits and withdrawals temporarily delayed.

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Dec 29, 2025 - 18:33 EST

Investigating

Some customers are experiencing an error message when withdrawing their XRP. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted Dec 29, 2025 - 17:47 EST
This incident affected: Digital Currencies (XRP Deposits & Withdraw).