Service Interruption
Incident Report for Gemini Exchange
Resolved
Service has been fully restored.
Posted 5 months ago. Jun 05, 2019 - 18:55 EDT
Monitoring
The underlying issue has been identified and action has been taken to fully restore affected services.
Posted 5 months ago. Jun 05, 2019 - 18:42 EDT
Investigating
Gemini is investigating a network disruption that is causing intermittent issues across various services such as logins, Crypto Deposits and withdrawals. All customers’ assets remain secure. We will provide further updates as necessary.
Posted 5 months ago. Jun 05, 2019 - 18:06 EDT
This incident affected: Exchange Web Interface, Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, Litecoin Deposits & Withdrawals, Zcash Deposits & Withdrawals, Bitcoin Cash Deposits & Withdrawals, Gemini Dollar Withdrawals & Redemptions, and Authy (Two-Factor Authentication).