Degraded Performance - Crypto Deposit Address Generation and Withdrawal Fee Estimates

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted 17 days ago. Mar 21, 2025 - 03:01 EDT

Investigating

We are currently investigating an issue affecting fee estimation and deposit address generation. All customer accounts and funds remain completely secure. Updates will be provided once they are available.
Posted 18 days ago. Mar 21, 2025 - 02:20 EDT
This incident affected: Crypto Deposits and Withdrawals.