UST Trading Pairs - Limit Only Mode

Incident Report for Gemini Exchange

Resolved

All UST Trading Pairs have been re-enabled.
Posted Nov 10, 2021 - 12:49 EST

Identified

Gemini has temporarily disabled non-USD retail trading for UST Trading Pairs, and moved the USTUSD Trading Pair to Limit Only trading mode accessible via the Gemini ActiveTrader interface. We will continue to provide updates as available.
Posted Nov 10, 2021 - 11:06 EST