Staking and Unstaking degraded performance. 11/12/2024
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 19:09 EST
Investigating
We are currently investigating an issue delaying the staking and unstaking process. All customer accounts and funds remain secure. Further updates to follow.
Posted Nov 12, 2024 - 18:05 EST
This incident affected: Gemini Mobile App: Uptime SLA 99.95% and Gemini Web UI: Uptime SLA 99.95%.