Instant orders are currently unavailable.
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 19:09 EDT
Investigating
We are currently investigating an issue with instant orders and we will be sure to update this page as soon as we have more information. All customer accounts and funds remain secure.
Posted Apr 29, 2024 - 18:33 EDT
This incident affected: Gemini ActiveTrader™, Gemini Mobile App: Uptime SLA 99.95%, Gemini Web UI: Uptime SLA 99.95%, and Gemini.com website.