Service Disruption -
Incident Report for Gemini Exchange
Resolved
The issue has been identified and resolved. No further impact is expected at this time.
Posted Nov 06, 2020 - 15:38 EST
Investigating
Gemini is investigating reports of potential service disruptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Nov 06, 2020 - 15:27 EST
This incident affected: Gemini ActiveTrader™ and Gemini Web UI.