Service Disruption - XRP Deposit & Withdrawals Temporarily Paused
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jul 21, 2024 - 09:24 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 20, 2024 - 23:30 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 20, 2024 - 23:29 EDT
Investigating
XRP deposits and withdrawals are temporarily paused. All customer accounts and funds remain secure. Further updates to follow.
Posted Jul 20, 2024 - 21:32 EDT
This incident affected: Digital Currencies (XRP Deposits & Withdraw).