Some public pages unavailable for Singapore users

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted Apr 12, 2026 - 23:42 EDT

Investigating

We are currently investigating an issue affecting access to certain public pages on www.gemini.com for users in Singapore. All customer accounts and funds remain secure.

In the meantime, you can continue to sign in and access your account at https://exchange.gemini.com/signin or the Gemini mobile app.
Posted Apr 12, 2026 - 21:53 EDT
This incident affected: Gemini.com website.