Solana Withdrawals Delay
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 14:53 EST
Investigating
We are currently investigating delays regarding Solana withdrawals. All customer accounts and funds remain secure. Further updates to follow.
Posted Jan 19, 2025 - 19:19 EST
This incident affected: Digital Currencies (Solana Deposits and Withdrawals).