API Settings Page Currently Down

Incident Report for Gemini Exchange

Resolved

This incident has been resolved.
Posted May 29, 2025 - 08:44 EDT

Investigating

The API Settings Page is currently down but we are working on identifying and resolving the issue.

We appreciate your patience and are actively working to ensure a smooth experience. All customer accounts and funds remain secure. Further updates to follow.
Posted May 29, 2025 - 07:16 EDT