Intermittent errors loading the credit card dashboard
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 04:45 EDT
Investigating
Third-party maintenance between 2-5AM EST causing intermittent errors loading the credit card dashboard. All customers’ assets remain secure. We will provide further updates as necessary.
Posted Apr 08, 2024 - 05:42 EDT
This incident affected: Gemini Credit Card™.