Gemini is performing routine maintenance in processing deposits of ETH and ERC-20s
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 16:33 EDT
Investigating
Gemini is currently undergoing routine maintenance in processing ETH and ERC-20 deposits. As a result, processing times for ETH and ERC-20 deposits may be delayed.
Posted Apr 16, 2024 - 14:50 EDT
This incident affected: Digital Currencies (Ethereum Deposits and Withdrawals).