Potential Service Disruption
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted May 03, 2022 - 12:42 EDT
Investigating
Gemini is investigating reports of potential service disruptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted May 03, 2022 - 12:28 EDT
This incident affected: Gemini ActiveTrader™, Gemini Web UI, Gemini Mobile App, and REST API.