BTC, ETH, ZEC deposits and withdrawals are temporarily unavailable
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 22, 2018 - 18:56 EDT
Monitoring
BTC, ETH, ZEC deposits and withdrawals are temporarily unavailable while we perform a required update. All customers’ assets remain secure. We will provide further updates as necessary.
Posted 3 months ago. Aug 22, 2018 - 18:49 EDT
This incident affected: Bitcoin Deposits & Withdrawals, Ethereum Deposits & Withdrawals, and Zcash Deposits & Withdrawals.