Potential Service Disruption
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Jun 19, 2022 - 05:27 EDT
Investigating
Gemini is investigating reports of potential service disruptions. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Jun 19, 2022 - 04:30 EDT
This incident affected: Gemini ActiveTrader™, Gemini Web UI, Gemini Mobile App, Exchange Trading Engine, REST API, and FIX API.