Filecoin Withdrawals are Temporarily Delayed
Incident Report for Gemini Exchange
Resolved
This incident has been resolved.
Posted Dec 07, 2020 - 23:10 EST
Update
We are continuing to investigate this issue.
Posted Dec 07, 2020 - 18:43 EST
Update
We are continuing to investigate this issue.
Posted Dec 07, 2020 - 18:41 EST
Investigating
Filecoin withdrawals are currently delayed while we investigate a technical issue. All customer accounts and funds remain completely secure. Further updates to follow.
Posted Dec 07, 2020 - 18:10 EST
This incident affected: Digital Currencies (Filecoin Deposits and Withdrawals).