Gemini Earn - Service Disruption
Incident Report for Gemini Exchange
Monitoring
Gemini Earn Deposits are currently unavailable. There are expected delays for in-progress Redemptions. Further updates to follow.
Posted Nov 17, 2022 - 12:36 EST
Investigating
Gemini Earn Deposits are currently unavailable. There are expected delays for in-progress Redemptions. Further updates to follow.
Posted Nov 16, 2022 - 08:51 EST
This incident affects: Gemini Earn.